Adventure Games Studio fr
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.


Forum d'entraide à la création de jeux d'aventure
 
PortailAccueilRechercherS'enregistrerConnexion
Le Deal du moment : -40%
-40% sur Logitech Z207 Système de ...
Voir le deal
30 €

 

 Problème de format

Aller en bas 
Aller à la page : Précédent  1, 2, 3
AuteurMessage
Crazy Legs
Grand Cliqueur Royal
Grand Cliqueur Royal


Nombre de messages : 1513

Date d'inscription : 09/01/2008


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 0:53

Voilà :

// room script file

#sectionstart room_a // DO NOT EDIT OR REMOVE THIS LINE
function room_a() {
// script for Room: Player enters room (after fadein)
PlayVideo ("intro1.avi", 0, 1);
}
#sectionend room_a // DO NOT EDIT OR REMOVE THIS LINE

Si tu préfère une image dis le :neutre:
Revenir en haut Aller en bas
LUniqueDan
Cliqueur Amateur
Cliqueur Amateur


Nombre de messages : 211

Date d'inscription : 05/07/2007


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 2:53

Bon, Crazy Leg on récapitule: En fait, ça serait bien que quand ca marche pas tu extrapolise un petit peu. "Ca ne marche pas" N'a pas beaucoup de sens. Au mieux, fournit le message d'erreur quand il se produit.

Moi tout fonctionne impec avec un :
Code:

PlayVideo("INTRO1.avi",1,1);
à 640x480 en couleur 16bits.

Dans l'ordre :
:reine: 1) Prends 3 petites secondes pour donner un nom tout en capital a ton fichier film, ainsi qu'a l'appel de celui-ci dans ton code. Tu isoles dès le départ
un probleme possible. C'est la première chose que j'ai fait quand j'ai recu ton film.

:travaille: 2) Assure-toi que le problème ne vient pas d'ailleur. Y'a t'il autre chose dans ta pièce?. As-tu programmé dans le main script?.
Comme il s'agit de la première fois que j'utilisait PlayVideo : j'ai testé dans un jeu tout neuf.

:bricole: 3) Expérimente un peu. Comme j'ignorais ta résolution de jeu, j'en ai profiter pour tester les différences entre les 'strectch to fits' etc... Ainsi qu'avec la résolution. Et *Bang*: de là, j'ai découvert qu'AGS bug quand la résolution du jeu ou du vidéo ne marche pas.

🆒 4) J'ai isolé le problème de la fenêtre vide "en prenant le bon bout de ma raison". En testant avec un background noir.

:bigsmile: 5) Prends-ça cool! et fait des excuses à Ramoul qui n'a pas mérité tes foudres.

Problème de format - Page 3 114419
Revenir en haut Aller en bas
Crazy Legs
Grand Cliqueur Royal
Grand Cliqueur Royal
Crazy Legs

Nombre de messages : 1513

Age : 27

Localisation : La Rochelle

Date d'inscription : 09/01/2008


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 4:40

Oui je suis un peu énervé en ce moment parce que je n'arrive pas à dormir, alors je vais lui envoyer un MP :sourire:
Alors je reprend tout, je vais essayer sur un projet tout neuf. Sinon je ne vois pas, j'essaierai avec des sprites.

Merci encore LUniqueDan

EDIT : super ! Problème de format - Page 3 114419

Dans un nouveau projet ça marche, allez je suis plus de mauvais poil, je vais y arriver je le sents :^^:

REDIT :

Voilà je pense avoir trouver la faille, ça marche quand on fait avec un projet "vide", mais avec un projet "défaut", il y a des paramètres qui font tout planté, il vient de me redemander un font avec accent, donc c'est qu'il va m'afficher le même message d'erreur.

LUnique si tu as encore ma vidéo essaye la avec un projet par défaut s'il te plaît, dis-moi si ça marche :bigsmile: .

Si non, je crainds qu'il ne faille tout recommencer à 0 :pleure:
Revenir en haut Aller en bas
Shai-la
Ouvrière en Chef de la Grande Tasse Bleue
Ouvrière en Chef de la Grande Tasse Bleue
Shai-la

Nombre de messages : 5829

Age : 42

Localisation : Montpellier

Date d'inscription : 17/04/2006


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 5:18

Si ça vient de la police, installe tout simplement une police avec accent...

_________________
Mon profil Facebook!
Mon site avec tous mes jeux, vidéos, illustrations etc
Revenir en haut Aller en bas
http://marionpoinsot.fr/video
Crazy Legs
Grand Cliqueur Royal
Grand Cliqueur Royal
Crazy Legs

Nombre de messages : 1513

Age : 27

Localisation : La Rochelle

Date d'inscription : 09/01/2008


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 5:58

Je sais tout ça, je sais même pourquoi il me demande ça (faut suivre, ya pas 6 page sur ce topic pour rien :clindoeil: )

Pages 2 tout en bas

Si AGS me demande une bonne police c'est tout bêtement parce qu'il veut m'afficher un message d'erreur (voir encore Page 2), ce message décrit le répertoire complet de la vidéo à charger, elle se trouve donc dans le répertoire : C:/Doc.... Téléchargement / Compil.../McJack....
Téléchargement étant composé d'accents, AGS ne les lisant pas, poum message d'erreur. (Je ne fait que répéter la page 2 et 3, en expliquant mieux ::XD: )

En fin de compte, changer les fonts avec accents ne me réglera pas le problème, néanmoins, question de temps c'est mieux d'avoir un message d'erreur dans AGS que d'attendre que le jeu s'arrête... charge... affiche le message... clic sur OK... etc...

Le message me disais que soit il n'avait pas trouvé la vidéo, soit qu'elle n'était pas dans le bon format...
Mais grâce à mes recherche plus hautes, et à la réponse que va sûrement me donner :bigsmile: LUnqiueDan...
Je surais quoi faire :ihih:
Revenir en haut Aller en bas
riseryn
Cliqueur Emérite
Cliqueur Emérite
riseryn

Nombre de messages : 559

Localisation : 77

Date d'inscription : 01/11/2007


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 8:07

Apparement ton message d'erreur n'a rien a voir avec la video si c'est celui que tu as donne page 2.
Ce message dit simpement que tu as utilisé un texte avec accent.
AGS ne sait pas afficher les accents avant la version 3.0.
De plus tu utilise une vieille version d'ags la 2.71.
pour le deuxieme message signale tu n'as pas mis apparement le nom complet de ta video
ce n'est pas PlayVideo ("intro1", 0, 1);
mais PlayVideo ("intro1.avi", 0, 1); qu'il faut mettre
Il faut aussi que la résolution de ton jeu soit au minimum en 16 bit pour avoir une bonne image car ta video est jouee a la resolution du jeu.
Donc un avi en 256 couleurs ca peux etre cocasse.

Profite en pour passer a la 3.01 qui devrait devenir dans quelques jours la nouvelle version officielle, elle supporte les accents et disposent de quelques fonctions comme le fait de pouvoir zoomer sur le background pour pouvoir tracer plus facilement les walk behind et autres hotspot.
Moi j'utilise une version 3.01 beta qui fonctionne sans soucis.

_________________
il y a deux choses d'infinis, l'univers et la connerie humaine.
En ce qui concerne l'univers je ne suis pas sur.
(Albert Einstein)
Revenir en haut Aller en bas
Crazy Legs
Grand Cliqueur Royal
Grand Cliqueur Royal
Crazy Legs

Nombre de messages : 1513

Age : 27

Localisation : La Rochelle

Date d'inscription : 09/01/2008


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 8:31

Ok merci ryseryn je ne pensais pas que cette version proposait d'autre fonction.
Alors pour en venir à tes réponses, j'ai tout bien mis en titre, ya pas de doute là dessus maintenant je l'ai renommé INTRO1.avi si c'est pour dire le nombre d'essai :^^:

Ma résolution est en 16 bits je vais essayé en 32 maintenant...

Et pour finir promis je passe en 3.1 :ihih:

Petite question, est-ce qu'il a rajouté des options dans le menu "actions" ?
Revenir en haut Aller en bas
riseryn
Cliqueur Emérite
Cliqueur Emérite
riseryn

Nombre de messages : 559

Localisation : 77

Date d'inscription : 01/11/2007


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 10:44

Oulala
la liste des choses ajoutees est tellement longue qu'il vaut mieux la consulter sur le site officiel.
Beaucoup de corrections de bugs, d'aménagements à l'interface.
La seule chose qui manque a mon avis est la gestion en interne de la 3D car les plugins et le module devellopes pour cela ne semblent plus etre suivis par leurs auteurs.

En ce qui concerne la 3.1 il ni y a plus les raccourcis d'actions comme dans les versions precedentes, c'est une version plus "programmeur".
Cela reviendra peut etre dans une version prochaine.
En attendant je te conseille plutot de passer à la version 2.72 qui ne te changera pas trop mais est la derniere version stable avant la 3.0.

_________________
il y a deux choses d'infinis, l'univers et la connerie humaine.
En ce qui concerne l'univers je ne suis pas sur.
(Albert Einstein)
Revenir en haut Aller en bas
LUniqueDan
Cliqueur Amateur
Cliqueur Amateur
LUniqueDan

Nombre de messages : 211

Age : 45

Date d'inscription : 05/07/2007


Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 EmptyMer 16 Avr 2008 - 21:21

Comme Riseryn le suggère, passe d'abord en AGS 2.72 C'est plus pratique pour débuter et un peu plus intuitif.

Si plus tard - lorsque ton jeu sera bien avancé - tu penses que tu as besoin d'une des super-méga fonctions de AGS 3, tu pourras facilement (4 ou 5 clicks) transformer ton jeu en nouvelle version.

Et au pire, quand ca bloque comme ça, le truc c'est encore d'avancer une autre partie du jeu en attendant que l'inspiration te revienne. Ça évite l'écoeurantite aigu. (un malaise très AGS)

:bricole:
Revenir en haut Aller en bas
Contenu sponsorisé




Problème de format - Page 3 Empty
MessageSujet: Re: Problème de format   Problème de format - Page 3 Empty

Revenir en haut Aller en bas
 
Problème de format
Revenir en haut 
Page 3 sur 3Aller à la page : Précédent  1, 2, 3
 Sujets similaires
-
» [format] Peasant
» Problème d'un Panda lvl 143
» [Mtgo] Momir Basic Format
» Problème de son sur mon nabaztag
» problème flux rss "paramètres non vide"

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Adventure Games Studio fr :: CREATION DE JEUX :: Questions / Réponses-
Sauter vers: